普通用户连接数据库报ORA-01035错误

 时间:2026-04-30 12:49:41

1、1.今天使用普通用户通过SQLPLUS连接数据库时报如下错误

普通用户连接数据库报ORA-01035错误

2、2.但在使用管理员译泪进行连接的时候就不会报这种错误。

普通用户连接数据库报ORA-01035错误

3、3.最后仔细想了一下是因为今天向数据库插入中文时无法插入,然后修改了系统信息造成的。修改后导瞧陵致普通用户没有了RESTRICTED SESSION权限。

普通用户连接数据库报ORA-01035错误

4、解决办法有两种

1.通过管理员用户直接赋给普通用户RESTRICTED SESSION权限,从图中可以看到,赋给权限后普通用户可以正常登录了。

普通用户连接数据库报ORA-01035错误

5、2.更改数称董孝据库的模式。下图中可以看到更改为正常模式后即可正常登录。

alter system disable restricted session;把系统修改为正常模式

alter system enable restricted session;把系统修改为限制模式

普通用户连接数据库报ORA-01035错误

  • 如何在3CDaemon自定义设置Syslog日志保存路径
  • 怎么安装mysql服务端
  • RTX如何设置讨论群
  • Sublime Text的列模式如何操作?
  • Windows作为NTP同步时间的服务器时,需要的设置
  • 热门搜索
    涟漪什么意思 生命的意义在于什么 是可忍孰不可忍什么意思 羊肉的功效与作用 紫苏油的功效与作用 艾绒的功效与作用 什么牌子的纸尿裤好 卫浴什么牌子好 最高人民法院院长什么级别 美容人才知识网